samedi 5 novembre 2011

XPS15z : Bumblebee & prise en charge de l'optimus

Suite à mon précédent billet, je me suis attardé sur la prise en charge de l'Optimus du XPS15z car j'ai trouvé que les ventilateurs marchaient un peu trop fort à mon goût.
J'ai donc suivi le tutoriel du projet Bumblebee qui propose via un script de mettre en place une gestion assez prometteuse de la puce Nvidia Optimus.

Je tiens à noter que les étapes suivantes sont risquées. Soyez sûr de ce que vous faites.
Je rappelle également que je suis sur Ubuntu 11.10 sur environnement xfce (distrib Voyager), la machine que j'ai sous la main est le XPS 15z L511z.

la nouvelle version de Bumblebee 2.4.1 conseille d'effectuer la marche suivante :

Install :
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install bumblebee
sudo usermod -a -G bumblebee [Nom d'utilisateur]

Gestion de l'énergie : 

sudo apt-get install acpi-call-tools

Ouvrir le fichier /etc/bumblebee/bumblebee.conf
et modifier les lignes 
    ENABLE_POWER_MANAGEMENT=Y
    STOP_SERVICE_ON_EXIT=Y

Créer ensuite le fichier /etc/bumblebee/cardon et ajouter ceci pour le XPS 15z L511z :
\_SB.PCI0.PEG0.PEGP._PS0

Puis créer le fichier /etc/bumblebee/cardoff et ajouter ceci pour le XPS 15z L511z :
\_SB.PCI0.PEG0.PEGP._DSM {0xF8,0xD8,0x86,0xA4,0xDA,0x0B,0x1B,0x47,0xA7,0x2B,0x60
,0x42,0xA6,0xB5,0xBE,0xE0} 0x100 0x1A {0x1,0x0,0x0,0x3}
\_SB.PCI0.PEG0.PEGP._PS3

qui correspond au tableau qui se trouve ici, à modifier en fonction de votre machine.

effectuer un petit reboot et voilà.

Pour tester bumblebee utiliser la commande optirun ...

mercredi 2 novembre 2011

XPS 15z : "Not enough memory to load specified image" et inspiron 15z

Venant d'avoir sous la main le tout nouvel inspiron15z (core i7, 8goRAM, 256goSSD, écran 1900x1080...), je me suis empressé de lui apposer la distrib Ubuntu qui m'est devenue aujourd'hui indispensable :)
J'ai choisi plus particulièrement la version Voyager 11.10 à la sauce XUbuntu disponible ici : http://voyager.legtux.org/

J'ai donc mis l'iso de la distrib sur ma clé usb comme d'habitude, un reboot et après avoir appuyé sur la touche Entrer sur "Installer Voyager", un beau plantage... et le fameux message "Not enough memory to load specified image"... argh!! non d'un bambou magique !!
Je me suis donc mis à chercher sur mon ami géant du net et j'ai trouvé ma solution :


    Tout d'abord à l'install lorsque le menu vous propose de modifier la ligne de commande, à l'endroit du "quiet splash", j'ai rajouté simplement les 3 mots clefs "noapic nolapic acpi=off" EDIT: mieux remplacer par "acpi=noirq" et hop l'install marche à merveille.

    Cependant après l'install, un petit reboot et là le problème persiste :
    je modifie donc maintenant la ligne du grub en appuyant sur la touche "e" et je rajoute les 3 mots clefs "magiques". Le reboot se passe à merveille.

    Enfin pour n'avoir pas à rentrer à chaque reboot la même manip, je modifie le grub grâce à un outil comme apt://grub-customizer et ajoute les  paramètres.

Et voilà !